WordPress: Automatically close comments on articles older than 28 days

ai2

WordPress is Automatically closing comments on articles older than 28 days.

All my websites allow people to comment on any post, no matter how old the post is. At least they should do, but it sometimes goes wrong.


These Adverts help to pay for this site.

In the WordPress settings there is an option to change that to stop people from leaving comments after a selected number of days, the default is 28 days.

It is located under the discussion settings, in the section “Other Comment Settings” and titled “Automatically close comments on articles older than 28 days”. (the 28 number is changeable).

My original setting was to leave it set at 28 days but not tick it, so the option is NOT activated. That has allowed all my posts to receive comments. That is vitally important on one site that gets regular comments on posts a few years old.

During the last couple of months something has changed, and I noticed that people no longer had the option to leave comments, and on checking this option, I noticed it had suddenly appeared as ticked, and therefore activated. No one could leave comments on posts older than 28 days.

I unticked that box to fix it, assuming I must have stuffed up at some stage and ticked it by accident. But it happened again, without me doing anything.


Agoda HolidaysAgoda HolidaysThese Adverts help to pay for this site.

On TWO of the FIVE sites that I have, the default setting of no comment after 28 days has automatically reset 3 times in one week. All five are hosted on the same shared host

I keep resetting the option back to allow comments, and even changed it to 9999 days on all five sites.  Three have remained at unticked and 9999 days for over a week, but two sites have defaulted back to being ticked and 28 days, three times in the last week or so.

This is the setting it defaults to

I keep changing it to this, which is how I have it set on three other sites, that have been OK for at least one week.

Timeline of changes:

  • 11pm 31st March 2018: I noticed 2 of 5 sites had defaulted back to being ticked, and I had to change them again.
  • 10am 3rd April 2018: I noticed the same 2 sites had defaulted again, and I changed them again.
  • 9am 5th April 2018: The same 2 sites had defaulted, and again, I changed them.

3 of my sites haven’t changed during this period.  I have a feeling that one of those three did change once before, but I cannot be sure.


201.1 - 547,130
Scroll down for Comments
5 1 vote
Article Rating
Subscribe
Notify of

This site uses Akismet to reduce spam. Learn how your comment data is processed.

18 Comments
Inline Feedbacks
View all comments

Most likely your host is doing it. Is your host owned by Endurance Group?

I manage around 150+ sites, and I have the same problem. Almost all of my sites are hosted on Bluehost, and some on Bluehost VPS, iWeb. Sites hosted on VPS and iWeb don’t have this problem.

They probably do it to reduce server load, so they can host more sites on same server and end up making more money.

Interesting point. I did change host. Although not sure at what point the problem stopped.

The same thing is happening to me, and I’m on JustHost which I believe is related to BlueHost. Have you discovered anything new since this update? I am starting to monitor plugin updates to see if that is resetting something.

Found this when googling. My site has the same problem. I keep noticing comments are closed. I reset the setting to allow comments. A few days later, it flicks back again. I’m on Bluehost. I have 25 plugins (please don’t judge) so troubleshooting this will not be easy because it’s so random.